Incident with ISP
Incident Report for Maxihost
Resolved
This incident has been resolved.
Posted Oct 15, 2019 - 12:08 GMT-03:00
Monitoring
We're continuing to monitor this issue.
Posted Oct 15, 2019 - 09:01 GMT-03:00
Identified
We've identified and are looking into issues with one of our ISPs.
Posted Oct 15, 2019 - 07:59 GMT-03:00
This incident affected: Regions (CH3 (Chicago)).